DEVICE UPDATES

Incident Report for Virgo

Resolved

The selected devices have been updated and are operating as expected.
Posted Oct 18, 2025 - 06:29 UTC

Investigating

Device updates will begin Friday October 17th, 2025 to select devices.
Posted Oct 14, 2025 - 20:42 UTC