Password Rotation Updates Wednesday July 24th, 2024
Incident Report for Virgo
Resolved
Password rotation is now in effect.
Posted Jul 24, 2024 - 21:41 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 23, 2024 - 18:05 UTC
Identified
We are adjusting our password rotation system tomorrow Wednesday, July 24th, 2024. Any clients not on SSO will be required to change their password. No issues or services are impacted.

Thanks!
Posted Jul 22, 2024 - 16:01 UTC
This incident affected: Web Services (Virgo Cloud, Trials).